It is currently Sat Apr 17, 2021 2:13 am
All times are UTC + 8 hours

Sonarr won't work with Mono beta app

Sonarr is a PVR for Usenet and BitTorrent users. It can monitor multiple RSS feeds for new episodes of your favorite shows and will grab, sort and rename them. It can also be configured to automatically upgrade the quality of files already downloaded when a better quality format becomes available.

Sonarr won't work with Mono beta app

Postby maartmail » Mon Nov 25, 2019 3:38 pm

Hello,

Sonarr does not work with Mono app version 5.18.1.0r1, it warns about this in the release notes but says that keeping the Mono beta app version 5.8.1.0.r9 installed should keep Sonarr working, it does not. Sonarr will not load even with the beta app installed, and it is not possible to keep only the beta app installed, as installing Sonarr will also install Mono version 5.18.1.0r1 along with it. I see there is a thread about this in the Mono part of the forum also, where people have similar issues.

Is it possible to fix Sonarr to work with the latest version of Mono?

Thank you!
maartmail
 
Posts: 22
Joined: Sat Jan 04, 2014 5:35 pm

Re: Sonarr won't work with Mono beta app

Postby Nazar78 » Tue Nov 26, 2019 7:40 pm

I've no issue with sonarr which in-app updated to 2.0.0.5338 running with the mono latest beta but I chose to downgrade mono due to jackett not starting up. Not sure why a beta became the streamline, poorly executed.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 287
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: Sonarr won't work with Mono beta app

Postby JeremyCreekit » Tue Dec 17, 2019 1:03 am

Just to echo the original post:

I mistakenly installed Mono 5.18.1.0.r1 which broke Sonarr so I tried reverting to the 5.8.1.0.r9 version listed in the Beta Apps section.

However, to revert it looks like I needed to uninstall 5.18.1.0.r1 first. So, I did this, which also uninstalled Sonarr. I then installed 5.8.1.0.r9.

I then reinstalled Sonarr which first forced me to download and install Mono 5.18.1.0.r1 again! So how do I avoid this and stick with 5.8.1.0.r9?

Is their perhaps a Mono apk that can be manually installed via the "Manual Install" option? Where does one find it and how do we prevent Sonarr from force-installing the latest version again?

Thanks
JeremyCreekit
 
Posts: 47
Joined: Mon Feb 10, 2014 4:28 am

Re: Sonarr won't work with Mono beta app

Postby Nazar78 » Tue Dec 17, 2019 1:44 am

JeremyCreekit wrote:Just to echo the original post:

I mistakenly installed Mono 5.18.1.0.r1 which broke Sonarr so I tried reverting to the 5.8.1.0.r9 version listed in the Beta Apps section.

However, to revert it looks like I needed to uninstall 5.18.1.0.r1 first. So, I did this, which also uninstalled Sonarr. I then installed 5.8.1.0.r9.

I then reinstalled Sonarr which first forced me to download and install Mono 5.18.1.0.r1 again! So how do I avoid this and stick with 5.8.1.0.r9?

Is their perhaps a Mono apk that can be manually installed via the "Manual Install" option? Where does one find it and how do we prevent Sonarr from force-installing the latest version again?

Thanks


The manual install option won't work as it will nag about already having latest version or something like that.

You need to do it within the ssh terminal. I've posted similar downgrade method but it's for ffmpeg. I'm replying on mobile so tough to recompose but you can simply replace it with mono. See here viewtopic.php?f=136&t=10703
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 287
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: Sonarr won't work with Mono beta app

Postby JeremyCreekit » Tue Dec 17, 2019 3:26 am

Nazar78 wrote: The manual install option won't work as it will nag about already having latest version or something like that.

You need to do it within the ssh terminal. I've posted similar downgrade method but it's for ffmpeg. I'm replying on mobile so tough to recompose but you can simply replace it with mono. See here viewtopic.php?f=136&t=10703


Thanks! Will give it a try.
JeremyCreekit
 
Posts: 47
Joined: Mon Feb 10, 2014 4:28 am

Re: Sonarr won't work with Mono beta app

Postby maartmail » Tue Dec 17, 2019 5:35 pm

Thanks for the help. I managed to "trick" the system by opening the management webpage twice, installing the Sonarr APK in one, and right away (after it checked Sonarr prerequisites) uninstalling the Mono mainstream release in the other, leaving just the Mono beta app installed. This got Sonarr working again. Not very elegant, but it got the job done. :D
maartmail
 
Posts: 22
Joined: Sat Jan 04, 2014 5:35 pm

Re: Sonarr won't work with Mono beta app

Postby JeremyCreekit » Wed Dec 18, 2019 4:02 am

Nazar78 wrote: You need to do it within the ssh terminal. I've posted similar downgrade method but it's for ffmpeg. I'm replying on mobile so tough to recompose but you can simply replace it with mono. See here viewtopic.php?f=136&t=10703


From reading your previous FFMPEG instructions it looks like the following steps are needed:

1) Determine your NAS architecture by SSHing into NAS and typing:
Code: Select all
uname -m

2) Find the previous package version URL here: http://appdownload.asustor.com

3) Install the package with the following command:
Code: Select all
wget -Offmpeg_3.3.2.r11.apk http://appdownload.asustor.com/0010_999_1504679933_ffmpeg_3.3.2.r11_x86-64.apk && apkg --install ffmpeg_3.3.2.r11.apk

I'm struggling with how to adapt Step 3 for Mono though. From the website, it looks like the previous version of Mono available is mono_5.14.0.177.r10

I have an AS-302T which uses the i686 architecture. I assume that this means that I need the i386 package rather than the x86_64 one, right? The filename for this package is 010_999_1541397964_mono_5.14.0.177.r10_i386.apk and the URL for this file is http://appdownload.asustor.com/0010_999_1541397964_mono_5.14.0.177.r10_i386.apk

How should I adapt the command in Step 3 given the above? Like so?
Code: Select all
wget -Omono_5.14.0.177.r10_i386.apk http://appdownload.asustor.com/0010_999_1541397964_mono_5.14.0.177.r10_i386.apk && apkg --install mono_5.14.0.177.r10_i386.apk
JeremyCreekit
 
Posts: 47
Joined: Mon Feb 10, 2014 4:28 am

Re: Sonarr won't work with Mono beta app

Postby Nazar78 » Wed Dec 18, 2019 9:01 am

Yes i686 is 32 bit so get the i386 package.

My system previously installed mono 5.8 so think you should try it instead of 5.14 but of course you can try see if 5.14 works. Restart the sonarr app once mono installed (toggle it off then on in the app central).

http://appdownload.asustor.com/0010_999 ... 9_i386.apk
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 287
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: Sonarr won't work with Mono beta app

Postby JeremyCreekit » Wed Dec 18, 2019 8:26 pm

Thanks! And any feedback on appropriately adapting the wget and install command? have i dont it correctly? for the Mono 5.8 link you shared, does this command look correct?

[EDIT] added space between wget get -O flag and filename for easier reading [/EDIT]

Code: Select all
wget -O mono_5.8.1.0.r9_i386.apk http://appdownload.asustor.com/0010_999_1532430877_mono_5.8.1.0.r9_i386.apk && apkg --install mono_5.8.1.0.r9_i386.apk

(I'm not sure if the up front -0... flag is supposed to look like that or not)
Last edited by JeremyCreekit on Wed Dec 18, 2019 11:20 pm, edited 1 time in total.
JeremyCreekit
 
Posts: 47
Joined: Mon Feb 10, 2014 4:28 am

Re: Sonarr won't work with Mono beta app

Postby Nazar78 » Wed Dec 18, 2019 10:54 pm

JeremyCreekit wrote:Thanks! And any feedback on appropriately adapting the wget and install command? have i dont it correctly? for the Mono 5.8 link you shared, does this command look correct?

Code: Select all
wget -Omono_5.8.1.0.r9_i386.apk http://appdownload.asustor.com/0010_999_1532430877_mono_5.8.1.0.r9_i386.apk && apkg --install mono_5.8.1.0.r9_i386.apk

(I'm not sure if the up front -0... flag is supposed to look like that or not)


Yup it's correct just copy & paste as a single line. The -O parameter is the local output variable that is the filename to save be it with or without space both works fine.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 287
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Next

Return to sonarr

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest