Page 1 of 1

max_queries_per_hour

PostPosted: Mon Feb 22, 2021 4:51 pm
by santtu1980
Damn.
For security reasons I've changed max_queries_per_hour setting to 1 for the root user. Now if I reset the root pswd from ADM the logging process succeeded but still cannot log in because "#1226 - User 'root' has exceeded the 'max_queries_per_hour' resource (current value: 1)"

Tried to login via SSH and reset that 'max_queries_per_hour' value. But linux is too hard for me. Can someone help to reset that setting.

Re: max_queries_per_hour

PostPosted: Tue Feb 23, 2021 11:44 pm
by santtu1980
Finally I solved this endless loop. Using try and fail-method several times!

Set SHH on on your NAS if it is not yet. (Services->Terminal->Enable SSH)
Reset mariaDB password. (open MariaDB settings->Reset Password) root/admin
Open Mysql from SSH terminal. (use putty or similar)
mysql -u root -p
enter password
reset mariaDB password after login
GRANT USAGE ON *.* TO 'root'@'localhost' REQUIRE NONE WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0;

If everything went well you can now log in via phpmyadmin