Page 1 of 1

MongoDB questions

PostPosted: Sat Feb 28, 2015 10:36 pm
by JeremyCreekit
Hi folks. Posting about Mongo here because I can't figure out where else to put this since there's no Mongo page in the 3rd party apps section and I can't see a general "Other" section either.

Anyway, a couple of questions about MongoDB please:

1) The Asustor version appears to be 32-bit only which limits you to a DB of 2GB. Is it possible to install the 64-bit version instead? If so, how do I do so please? I'm a Linux newbie.

2.1) As I said, I'm a Linux newbie. Mongo needs a database folder which I assume will be under Home\data\db. However, if I try run "mkdir -p \data\db" it tells me I need admin rights but if I run "sudo mkdir..." it can't find sudo and su doesn't work either. What do I need to do here?

2.2) Related to the above, if I just create Home\data\db using the File Explorer in ADM, Mongo doesn't recognise those folders as being created. Am I creating them in the right place?

Thanks!

Re: MongoDB questions

PostPosted: Mon Mar 09, 2015 11:12 pm
by maxani
Hi @JeremyCreekit.

I'm the maintainer of the MongoDB app.

The version is both 32/64 bit.

I don't understand your next questions.

Indeed you don't have anything to do. You install MongoDB from the AppCentral, you wait. An empty and fresh database is created at /volume1/MongoDB folder.
Then you can connect to and manage the MongoDB cluster by any tool you want with these default credentials : admin / mongodb.
Security is then up to you.

Best regards,

Re: MongoDB questions

PostPosted: Wed Apr 29, 2015 8:53 pm
by carlos_lema
Hi @maxani,

Thanks for the response. I am starting to kick the MEAN stack around, and I just stalled mongoDB yesterday -- BTW, which tool are you using to manage it?

I installed phpmongodb but it asks for the php_mongo module, I tried running:
Code: Select all
$ sudo pecl install mongo

but for some reason this is not recognized by busybox (*nix flavor on the Asustors)

Thanks in advance for your help,
\\ carlos

Re: MongoDB questions

PostPosted: Tue May 12, 2015 3:45 am
by maxani
Hi @carlo_lema.

There is no MongoDB php driver included in Asustor's PHP.
But you can add yours. If you use PHP 5.5 APK find a version of the mongo.so extension for PHP API 20121212. One from Ubuntu repos does the trick.
Then you add it in the same folder as the others and enable it in the php.ini.

Good luck.

Re: MongoDB questions

PostPosted: Mon Apr 01, 2019 4:19 am
by daniel
hi xani

i came to informe that de mongodb version 2.6.7 is not working on the nas AST1002N
I can installl and create de share folder. but when i try to run using the terminal show me a series of error. ;)