It is currently Mon Jun 14, 2021 11:14 pm
All times are UTC + 8 hours

Nothing happened when installing - what port??

Apache Subversion (often abbreviated SVN, after the command name svn) is a software versioning and revision control system distributed under an open source license.

Nothing happened when installing - what port??

Postby kalleankan » Wed Jan 13, 2016 3:34 am

I installed subversion as an app in my NAS. No new icon was shown, no new services was displayed, no new settings possiblity opened, no new folders were created, no new processes was created. I tried restarting the NAS without anything changed. I dont even know what port to connect to. Nor do i know what protocol I can use.

I later tried to connect to the NAS via my Subversion client anyways. I tried various ports, locations and protocols without luck.

Please dont refer to a book as you did last post. Wont answer Asustor specifcs. What port should i connect to? What address? What protocol can i use (svn, http, https, file, other?)
Posts: 6
Joined: Thu Dec 26, 2013 4:22 am

Re: Nothing happened when installing - what port??

Postby kalleankan » Thu Jan 14, 2016 4:05 am

Ok, so i decided to give it a try to install it anyways, without any documentation from Asustor. Wasted a perfectly half day. But in case anyone is reading this here it goes.

[*] Installed the Subversion App on the NAS
[*] Created the repository by SSH-ing into the NAS and ran: svnadmin create /home/admin/subversion_repos
[*] I created a new project by: svn mkdir /home/admin/subversion_repos/nyttProject
[*] I edited the /home/admin/subversion_repos/conf/svnserve.conf file so:
anon-access = read
auth-access = write
password-db = passwd
Which I guess means anonymous access should have read rights, if you can authenticate, then you shoule have write access as well. Then the password-db defines the file where we store username/passwords.
[*] I edited the /home/admin/subversion_repos/conf/passwd file and added a user with a super simple password.
[*] Then I ran: svnserve -d -r /home/admin/subversion_repos

This should have crated a Subversion repo with the Subversion deamon, responding to the svn:// protocol on port 3690. But no.

Here my luck ran out. I tried connecting the the repository both via my Eclipse Subversion client, from a turtoise client from another computer, and lastely i even tried just checking out a project locally on the NAS. All failed with various odd error messages. Here is one error message when I try to import a project locally from the NAS itself.
admin@NAS:/volume1/home/admin/subversion_repos $ svn import -m "yo" --username myuser--password mypassword /volume1/Download/utorrent/log/ file:///home/admin/subversion_repos/testproject5
svn: E000022: Can't set position pointer in file '/home/admin/subversion_repos/db/revs/0/0': Invalid argument

Another error message is when I try to checkout the code locally on the NAS as well
admin@NAS:/volume1/Download/utorrent/log $ svn co svn://
svn: E210002: Unable to connect to a repository at URL 'svn://'
svn: E210002: Network connection closed unexpectedly

And yes, I've tried various different formats, protocols, addresses. All gives various errors

For being an official app from ASUSTOR, they have made it all but userfriendly. Any help is appreciated.
Posts: 6
Joined: Thu Dec 26, 2013 4:22 am

Re: Nothing happened when installing - what port??

Postby Hikari » Sat Jan 16, 2016 10:56 pm

Thanks for your hardwork kalleankan. I also tried to install Subversion and had no luck.

For serious development, I suggest using or I use the free plan of and it's awesome.

Still, I use subversion for controlling some games files. Oblivion in example has a very complex plugin system, I install a lot of plugins on it and also developed a few. These games need a lot of storage and they arent so important that I'm willing to play subversion cloud storage for them. Therefore I remain using local Subversion.

I'd love to move my local Subversion server into my NAS. I know it doesn't have a lot of CPU and RAM to spare, but I'd like at least to try.

I still thank Asustore for providing it (since we're unable to apt-get/yum or gcc compile), but we need some support on the apps provided.
Posts: 20
Joined: Fri Dec 18, 2015 8:04 am

Return to Subversion

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest