It is currently Fri Jan 22, 2021 11:44 pm
All times are UTC + 8 hours

Constant disk activity

Re: Constant disk activity

Postby nero78 » Sun May 29, 2016 6:28 pm

Why is the diagnostic tool only reporting write operations? Why not read? If the disks have problems spinning down, it could just as likely be because read operations...
nero78
 
Posts: 76
Joined: Sat Mar 05, 2016 7:01 pm

Re: Constant disk activity

Postby orion » Mon May 30, 2016 10:59 am

nero78 wrote:Why is the diagnostic tool only reporting write operations? Why not read? If the disks have problems spinning down, it could just as likely be because read operations...

Yes, I found the same problem too. I sent a support request to asustor.
User avatar
orion
 
Posts: 2867
Joined: Wed May 29, 2013 11:09 am

Re: Constant disk activity

Postby torarnek » Sat Aug 13, 2016 8:50 pm

So because ADM queries the WD red disk for status every 10 seconds, and because that produces this sound, I would conclude that they are not compatible.
torarnek
 
Posts: 13
Joined: Wed Mar 02, 2016 7:42 pm

Re: Constant disk activity

Postby torarnek » Sat Aug 13, 2016 8:53 pm

I think the Asustor developers should figure out how to query the disk for status without producing this noise.
torarnek
 
Posts: 13
Joined: Wed Mar 02, 2016 7:42 pm

Re: Constant disk activity

Postby orion » Mon Aug 15, 2016 12:38 pm

torarnek wrote:I think the Asustor developers should figure out how to query the disk for status without producing this noise.

I think asustor can do nothing. It's caused by HDD, rather than software. :(
User avatar
orion
 
Posts: 2867
Joined: Wed May 29, 2013 11:09 am

Re: Constant disk activity

Postby KiT » Thu Oct 13, 2016 4:51 pm

By the way same story with HGST 2x 3TB HDD HDN724030ALE640 setup as RAID1 and configure as Volume1
KiT
 
Posts: 16
Joined: Thu Mar 03, 2016 12:55 am

Re: Constant disk activity

Postby RainCaster » Sat Feb 11, 2017 3:37 am

I have my 6208 set up as two arrays: The first is 5 5TB drives in RAID 6, and the second is two 4TB drives in RAID 1, plus a hot spare. My system comes up and immediately begins some sort of scanning thing on the RAID 6 array, and after a day it finishes and the system calms down. The monitor shows several HddLightThread2 and HddLightThread8 are active, along with php and python, which are probably the management website I'm viewing from.

As soon as I disabled the Photo Gallery app, all that disk noise went away. So it apparently does not keep a static list of discovered images, but rebuilds it on every power up. I will gripe about this in the Photo Gallery section...
RainCaster
 
Posts: 16
Joined: Mon Feb 06, 2017 11:37 pm

Re: Constant disk activity

Postby js_online » Mon Jan 08, 2018 9:14 am

Any update on this?

This is not about reading temperature, this issue is about writing constantly (each minute) block 8 on raid.
I have the following setup on my AS6204T for home use:
1. Volume 0, SSD 120 single
2. Volume 1, Raid1, disk1 Seagate IronWolf NAS 4TB ST4000VN008
3. Volume 1, Raid1, disk2, Seagate IronWolf NAS 4TB ST4000VN008
4. MyArchive, Seagate IronWolf NAS 4TB ST4000VN008

Disk 4 hibernates and sleeps well. NAS led perfectly indicates this. Disk is the same model as used in Raid.
Disk 2, 3 on RAID 1 are spinning up and down all the time, each 1-2 minutes. All apps disabled (only Python is active), nothing disk related appears in diagnostic tool. No info in system log.

I checked in Putty filesystem read/writes by and I see constant writes on block 8 on Raid disks.
echo 1 > /proc/sys/vm/block_dump

[51079.769046] md0_raid1(1331): WRITE block 8 on sda2 (1 sectors)
[51079.769083] md0_raid1(1331): WRITE block 8 on sdc2 (1 sectors)
[51079.769102] md0_raid1(1331): WRITE block 8 on sdb2 (1 sectors)

See video attached (use headphones to hear ticks and disk activity).
0:36 - spins up, read write on disk 2 or disk 3 (disk 1 is SSD, no sound), disk 4 is hibernating (same model as raid).
1:08 - spins down.
Everything repeats after 30-40seconds.
js_online
 
Posts: 6
Joined: Mon Jan 08, 2018 9:02 am

Re: Constant disk activity

Postby Kapitein Haak » Mon Jan 08, 2018 5:04 pm

Hello js_online,

I have (about) the same thing where I get constant writes in the diagnostic log. This will only happen when I have ADM active. When I close the ADM webpage and let the NAS be on itself, the disks will not get accessed. When I open ADM a bit later and check the diagnostic tool again (it will keep running in the background), the writing starts again. Please check if the diskwrites stop when you logout of ADM.

Best regards,
Kapitein Haak.
"What would the world be like without Captain Hook?"
---
"Homo sapiens non urinat in ventum" (A wise man doesn't piss into the wind), only in Amsterdam:
https://www.google.nl/maps/@52.36289,4. ... 312!8i6656
User avatar
Kapitein Haak
 
Posts: 333
Joined: Tue Oct 15, 2013 2:40 pm
Location: Stranded on the Dutch coast.

Re: Constant disk activity

Postby js_online » Mon Jan 08, 2018 5:27 pm

Kapitein Haak wrote: This will only happen when I have ADM active.


This is not ok in any scenario. If ADM is active it should not spin down.
I checked the same with ADM disconnected, with LAN disconnected, exactly the same issue.

I forgot to mention that there is no info in Diagnostic Tool for my events. You can see them only from command line in Putty using file system read/write monitoring.
Last edited by js_online on Tue Jan 09, 2018 5:09 pm, edited 1 time in total.
js_online
 
Posts: 6
Joined: Mon Jan 08, 2018 9:02 am

PreviousNext

Return to [Official] For AS61XX/62XX Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest