It is currently Sat Jan 23, 2021 7:00 am
All times are UTC + 8 hours

Problem mounting external USB HDD AS6204T

Problem mounting external USB HDD AS6204T

Postby huffie » Fri Oct 11, 2019 10:49 pm

Hi all, have a couple of questions to ask with regards to connecting to external USB drive. I noticed that if an external USB drive is connected to Asustor prior power up, upon powering up Asustor will not be able to boot up (have experienced the same with AS302T). Is this normal that I have to unplug USB drive prior boot up?

Secondly, recently one of my drives (on bay 2) on AS6204T has been degraded (due to dying disk) , after removing the degraded drive I'm unable to get my USB drive mounted. Based on the log, I see this line
Code: Select all
2019-10-11T21:03:38.643031+08:00 AS-6204T kernel: [78641.501862] scsi 8:0:0:0: Direct-Access     Generic  HDD              0    PQ: 0 ANSI: 0
2019-10-11T21:03:38.644920+08:00 AS-6204T kernel: [78641.503744] sd 8:0:0:0: Attached scsi generic sg4 type 0
2019-10-11T21:03:38.649931+08:00 AS-6204T kernel: [78641.508935] sd 8:0:0:0: [sde] Attached SCSI removable disk
2019-10-11T21:07:09.858067+08:00 AS-6204T smbd[21882]: [2019/10/11 21:07:09.857931,  0, pid=21882, effective(0, 0), real(0, 0)] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)
2019-10-11T21:07:09.858133+08:00 AS-6204T smbd[21882]:   Unable to open printcap file /etc/printcap for read!

However, as I'm unable to access the drive I tried to do a smartctl --all /dev/sde and I got the following message
Code: Select all
smartctl 6.3 2019-01-10 r52 [x86_64-linux-4.4.24] (local build)
Copyright (C) 2002-14, Bruce Allen, Christian Franke, www.smartmontools.org

/dev/sde: Unknown USB bridge [0x2537:0x1066 (0x100)]
Please specify device type with the -d option.

Use smartctl -h to get a usage summary

Could it be coincidentally that the external USB dock is faulty or is it because bay 2 drive is empty resulting some issues? I'm currently awaiting the delivery of replacement HDD.

Thanks!
huffie
 
Posts: 31
Joined: Wed Jan 29, 2014 5:10 pm

Re: Problem mounting external USB HDD AS6204T

Postby father.mande » Sat Oct 12, 2019 5:28 pm

Hi,

For USB drive, be sure that disk in USB don't have any partition flagged as "boot partition", to avoid problem with BIOS (or EFI) that search to boot on USB before D.O.M. (for recovery)
... if boot flag partition exist, deactivate it (use parted in Linux with "flag" management option ... same tools exist on Windows for Windows partition or generic tools like Acronis disk image, etc.).

Tested on other NAS (multiple brand) never on AS6204T ...
Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1069
Joined: Sat Sep 12, 2015 2:55 am

Re: Problem mounting external USB HDD AS6204T

Postby huffie » Mon Oct 14, 2019 9:42 am

Thanks Philippe for the suggestion, will try once I can get the Asustor to recognize my USB dock. For some reason I'm still having issues trying to mount (have replaced my degraded HDD, so now all bays are occupied).
I noticed there's this message in the log
Code: Select all
2019-10-14T09:33:00.344532+08:00 AS-6204T kernel: [  431.368773] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
2019-10-14T09:33:00.356610+08:00 AS-6204T kernel: [  431.381144] usb 2-2: New USB device found, idVendor=2537, idProduct=1066
2019-10-14T09:33:00.356666+08:00 AS-6204T kernel: [  431.381150] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
2019-10-14T09:33:00.356693+08:00 AS-6204T kernel: [  431.381153] usb 2-2: Product: NS1066
2019-10-14T09:33:00.356700+08:00 AS-6204T kernel: [  431.381157] usb 2-2: Manufacturer: Norelsys
2019-10-14T09:33:00.356737+08:00 AS-6204T kernel: [  431.381160] usb 2-2: SerialNumber: 0123456789ABCDE
2019-10-14T09:33:00.357536+08:00 AS-6204T kernel: [  431.382061] usb-storage 2-2:1.0: USB Mass Storage device detected
2019-10-14T09:33:00.358541+08:00 AS-6204T kernel: [  431.383061] scsi host7: usb-storage 2-2:1.0
2019-10-14T09:33:28.206533+08:00 AS-6204T kernel: [  459.230760] usb 2-2: Disable of device-initiated U1 failed.
2019-10-14T09:33:33.326538+08:00 AS-6204T kernel: [  464.350759] usb 2-2: Disable of device-initiated U2 failed.
2019-10-14T09:33:33.502534+08:00 AS-6204T kernel: [  464.526945] usb 2-2: reset SuperSpeed USB device number 3 using xhci_hcd
Can anyone enlighten me on this? Thanks
huffie
 
Posts: 31
Joined: Wed Jan 29, 2014 5:10 pm

Re: Problem mounting external USB HDD AS6204T

Postby father.mande » Mon Oct 14, 2019 5:54 pm

Hi,

Difficult, because "Disable of device-initiated xxx failed." can occurs for lot of reasons
... initialize failed can be the result of :
... ... hardware failure (rare if device is recognize)
... ... USB2 device on USB3 or reverse due to low or high power delivered
... ... not updated firmware for the USB dock (your must be at least at : Norelsys NS1066 Sata III/USb 3.0 controller Firmware Version 2.67 (if I don't do an error))
... ... bad format ex. exfat but not supported
... ... bad partition format (ex. some NTFS build on Windows, can't be recognize) ... in this case, only a partition format done in the NAS can solve the problem.
... ... top many files or / and folder on the root USB device
... ... Linux 32 bits limit (do uname -a in a terminal) or not updated libraries for x86_64 (Asustor as lot of NAS provider keep old system libs (ex. 2.22 when 2.27 is used for same kernel level)
... ... etc.

So only a system trace can help (if it's not a "common" problem) ... please, call the support
Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1069
Joined: Sat Sep 12, 2015 2:55 am

Return to [Official] For AS61XX/62XX Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest