It is currently Sun Aug 18, 2019 10:30 am
All times are UTC + 8 hours

[HOW TO] Setup owncloud on your ASUSTOR NAS

Share your awesome tips and tricks here.

[HOW TO] Setup owncloud on your ASUSTOR NAS

Postby leecool » Tue Jun 18, 2013 9:56 am

Some folks write me saying that he is not able to get owncloud running on ASUSTOR NAS.
Hereby, showing you the simple steps to get it run~

[Preparations]
1. Go to “Service/MySQL Server” and make sure it is running.
2. Install “phpMyAdmin” via App Central to manage MySQL server.

[Create a database for owncloud]
1. Launch “phpMyAdmin” and login (default acc/pass: root/admin)
2. Click “Users” tab to create a new user.
3. Fill-in username, password , host and select “Create database with same name and grant all privilege”
own1.png
own1.png (61.9 KiB) Viewed 12039 times


[Setup owncloud]
1. Install owncloud from App Central and launch it.
2. Crate the administrator account and then select “Advanced” setting.
3. Configure the database as “MySQL” and fill-in the account, password and database name that you just great at last step.
4. Click “finish” and let ownclod do all the settings…..
own2.png
own2.png (29.15 KiB) Viewed 12039 times


Enjoy!
leecool
 
Posts: 24
Joined: Wed Mar 13, 2013 5:53 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby sys » Thu Jul 04, 2013 5:47 pm

wow, this is great!!! :D :D :D
sys
 
Posts: 188
Joined: Thu Jun 14, 2012 8:13 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby heathwil » Fri Nov 01, 2013 6:07 pm

Thanks that is good for a new owner!

Can this please be updated on how to enforce https? I am having issues with this.

Thanks
heathwil
 
Posts: 2
Joined: Fri Nov 01, 2013 4:04 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby stevenilsen » Sat Nov 09, 2013 12:34 am

Hi!
Is there some more thins that need to be activated and set up first? The phpMyAdmin needs HTTPS pages it looks like.
Its giving me the error: ssl_error_rx_record_too_long
Can log in.
stevenilsen
 
Posts: 2
Joined: Sat Nov 09, 2013 12:32 am

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby leecool » Sat Nov 09, 2013 9:40 am

Hi,
The "enforce https" can only be enable when you connect to owncloud with https.
So, please login ADM and enable "Secured Web server (SSL)" on the service settings.
And then you will be able to connect to owncloud via Https. ex https://yourip/owncloud/
Don't forget to mapping the SSL port (443) via EZ-Router!
leecool
 
Posts: 24
Joined: Wed Mar 13, 2013 5:53 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby Tanotron » Sun Dec 15, 2013 6:24 am

Hi,
I would like to post an update about ownCloud installation on asustor nas.

Installation steps

On the NAS
1. Go on the admin pannel
2. Open App Central then install owncloud
3. Clic on the service icon, Web Server tab then enable ssl (the connections between your nas and your client will be secured)
Image
4. Launch the ownCloud web interface (clic on the ownCloud icon)
Image
5. Connect using your main login informations for the NAS
6. Create the needed user account
Image

Client side
7. Install an ownCloud client (http://owncloud.org/install/)
8. During the setup use your NAS'url (you may use the asustor ddns)
It sould be similar to this : https://yournas.myasustor.com:443/owncloud
Don't forget the "https" and the port part ":443"
Image
8. Login with an account created previously

Hope this may help,
Tan
Tanotron
 
Posts: 1
Joined: Sun Dec 15, 2013 6:02 am

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby fwhamm » Sat Jan 18, 2014 10:05 pm

I just installed Owncloud on my AS-302T via Web installer http://owncloud.org/install/ using this thread's information. It worked like a fly :-)

One hazard I stumbled upon was the Mac client when connecting on https via hostnames. Using IP address within local net worked fine but as soon as I used hostnames (local or via <server>.myasustor.com) I got error messages. With Windows client it worked fine.

I did some research in owncloud forums and found the solution. You need to add some virtual host entries for the webserver. With Asustor Portal you don't need to hassle with Apache config. Just open Services in Asustor Portal and add those hostnames you want to connect with including appropriate port and directory (I rubbished my <server>):

asustor_owncloud_virtual_hosts.jpg
Add virtual host for access Owncloud with Mac client via https
asustor_owncloud_virtual_hosts.jpg (60.8 KiB) Viewed 10994 times


Hope this helps when someone runs into the same trouble ;-)

BTW: Web installer installs 6.0a and it seems to work so far...
Web: @fwhamm, About
Storage: AS-6202T, AS-302T
fwhamm
 
Posts: 25
Joined: Sat Jan 04, 2014 8:07 pm
Location: Selzen, Germany

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby wde » Sun Jan 19, 2014 9:39 pm

Anyone else having problems signing in to phpMyAdmin using ADM 2.1 BETA?

Default user/password don't seem to work.
Owncloud gets error message "Unable to connect to database"
Owncloud Android app has no problem with access.
My NAS: AS-602T ADM: 3.3.1.RIH2 Router: Hitron CODA-4582
wde
 
Posts: 186
Joined: Sun Jun 16, 2013 5:00 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby wde » Mon Jan 20, 2014 1:59 am

wde wrote:Anyone else having problems signing in to phpMyAdmin using ADM 2.1 BETA?

Default user/password don't seem to work.
Owncloud gets error message "Unable to connect to database"
Owncloud Android app has no problem with access.

Since I'm still experimenting on how this all works (and had little data to lose) I solved my problem by:

Uninstalling owncloud and phpMyAdmin.
Re-installing phyMyAdmin
In phyMyAdmin I removed any old traces of owncloud.
Re-installed owncloud with instructions from above.
Everything seems back to normal.
My NAS: AS-602T ADM: 3.3.1.RIH2 Router: Hitron CODA-4582
wde
 
Posts: 186
Joined: Sun Jun 16, 2013 5:00 pm

Re: [HOW TO] Setup owncloud on your ASUSTOR NAS

Postby wde » Mon Aug 25, 2014 2:29 pm

Updated to latest release of Owncloud now can't sign in via ADM. I get the following error.
You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domain" setting in config/config.php. An example configuration is provided in config/config.sample.php.

I've looked at the samples via link provided but my lack of coding skills and where to find files to update and how to update them is over my head.
Any help on finding and updating the appropriate file on Asustor NAS would be appreciated.
My NAS: AS-602T ADM: 3.3.1.RIH2 Router: Hitron CODA-4582
wde
 
Posts: 186
Joined: Sun Jun 16, 2013 5:00 pm

Next

Return to Tips & Tricks

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest