It is currently Sun Oct 25, 2020 8:13 am
All times are UTC + 8 hours

XBMC Audio Sync Issue

Currently XBMC can be used to play almost all of the popular audio and video formats around. It was designed for network playback allowing you to stream multimedia directly from your NAS via HDMI to any monitor or directly from the internet using practically any protocol available.

Re: XBMC Audio Sync Issue

Postby keagy » Wed Jun 18, 2014 9:59 am

Probably the only current fix to those having audio synch issues is set XBMC to HDMI pass-thru connected to an AVR to do the audio decoding.
keagy
 
Posts: 28
Joined: Sat May 24, 2014 1:30 pm

Re: XBMC Audio Sync Issue

Postby piflechien » Sat Jun 21, 2014 8:23 pm

No, I have an AVR (Yamaha) and set xbmc to HDMI output and have the lipsync issue, around 450ms out of sync
piflechien
 
Posts: 3
Joined: Sat Jun 21, 2014 8:18 pm

Re: XBMC Audio Sync Issue

Postby eriikoo » Sun Jun 22, 2014 7:33 am

piflechien wrote:No, I have an AVR (Yamaha) and set xbmc to HDMI output and have the lipsync issue, around 450ms out of sync

I confirm to. I have kinda the same setup and have the lip sync issue. The AVR does not do the lip sync correctly. More like that the XBMC does not work correctly with HDMI as sound output.
eriikoo
 
Posts: 7
Joined: Thu May 08, 2014 4:55 am

Re: XBMC Audio Sync Issue

Postby jchasles » Mon Jun 30, 2014 2:29 am

Hi,

I have the same issue :(

AS-202TE
ADM 2.2.0R6O2
XBMC 12.3r13
Xorg 1.7.1.302

NAS directly connected to Samsung tv with HDMI, audio configure to "Analogique" in XBMC
jchasles
 
Posts: 5
Joined: Mon Jun 30, 2014 2:25 am

Re: XBMC Audio Sync Issue

Postby twicetimes » Sun Jul 06, 2014 8:25 pm

Just by way of a workaround until these XBMC issues are (hopefully) resolved - the best solution I can find is binding a key (or remote button) to the 'audio delay minus' and 'audio delay plus' settings using the key map editor add-on. This way, at least it's just a matter of tapping a button a few times to sync up the audio on whatever you're watching. The delay is more pronounced the higher quality the video is, so sadly you can't really set it to be the same for all files.

Here's hoping a 'proper' solution comes along soon. I don't know if it's something XBMC 13.1 will fix, or some other asustor/driver update.
twicetimes
 
Posts: 2
Joined: Sun Jul 06, 2014 8:21 pm

Re: XBMC Audio Sync Issue

Postby phantasmnz » Fri Jul 11, 2014 5:37 am

Thanks for this - yes this is mildly less annoying than forward and back skipping for 5 mins trying to get it somewhere near.
Hey Asustor - how about giving us the option of more remote buttons we can map to the internal IR receiver then we could actually map remote buttons to do this manual sync (I can only get the keyboard to do this)


Sent from my iPhone using Tapatalk
phantasmnz
 
Posts: 54
Joined: Tue Dec 31, 2013 6:40 am

Re: XBMC Audio Sync Issue

Postby z1022 » Sat Jul 12, 2014 11:14 pm

How do you use keyboard ??
z1022
 
Posts: 75
Joined: Mon Oct 07, 2013 1:36 pm

Re: XBMC Audio Sync Issue

Postby Kerry » Mon Jul 14, 2014 7:53 am

You just simply connect the USB keyboard to NAS USB connector and then you can use it...
Kerry
 
Posts: 456
Joined: Wed Jul 03, 2013 9:35 pm

Re: XBMC Audio Sync Issue

Postby twicetimes » Tue Jul 15, 2014 5:15 am

Kerry wrote:You just simply connect the USB keyboard to NAS USB connector and then you can use it...


Or get one of these:

http://www.scan.co.uk/products/keysonic ... -trackball

This is basically my remote control now.
twicetimes
 
Posts: 2
Joined: Sun Jul 06, 2014 8:21 pm

Re: XBMC Audio Sync Issue

Postby chansir » Tue Jul 22, 2014 12:18 pm

I got no luck with the KeyMapper add-ons. The configure button is grey out.

I then look into the details of how to manually create the keymap without the GUI.

I created the following keyboard.xml file (https://mega.co.nz/#!s8d1FSJQ!BZLc8oUWddccWXGZ7voQP6eT9tx5_bnrjuem6DBRoGQ) and copy over to the folder (Using the XBMC File Manager)
special://profile/keymaps/

Reboot XBMC and now I can use my wireless keyboard to:

press UP and DOWN to change audio delay and try sync with the video quickly.

I added some other key presses as well.

They only work when the video is played FULLSCREEN so other global key mappings are not affected.

keyboard.xml content
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
<keymap>
<fullscreenvideo>
<keyboard>
<s>NextSubtitle</s>
<up>AudioDelayPlus</up>
<down>AudioDelayMinus</down>
<right>StepForward</right>
<left>StepBack</left>
<f>BigStepForward</f>
<b>BigStepBack</b>
<space>Pause</space>
<a>AudioNextLanguage</a>
</keyboard>
</fullscreenvideo>
</keymap>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
chansir
 
Posts: 5
Joined: Tue Jul 01, 2014 3:09 pm

PreviousNext

Return to XBMC

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron