It is currently Thu Dec 12, 2019 8:59 pm
All times are UTC + 8 hours

HTTP ERROR 403

Eynio is a Smart Home application created for easily controlling, scheduling and manipulating multiple smart devices.

Re: HTTP ERROR 403

Postby Narayan » Tue Jul 17, 2018 7:23 pm

Please, forget about Photo Gallery. It was just an example of 2 Web services colliding on Asustor that still is unresolved.

What can I do to run Eynio Server?

Thank you
Narayan
 
Posts: 11
Joined: Fri Mar 11, 2016 4:36 am

Re: HTTP ERROR 403

Postby sksbir » Tue Jul 17, 2018 8:45 pm

hi
I don't know anything about your server, but you should connect with ssh session to you NAS and check if your server is working.
I have the same problem with squid proxy : no process although activated in adm interface ( this will be a future topic ).

Or check process list in performance tool, with your server started, and stopped, and find if they are differences in process list.
sksbir
 
Posts: 322
Joined: Tue Aug 25, 2015 9:23 pm

Re: HTTP ERROR 403

Postby Narayan » Tue Jul 17, 2018 11:57 pm

i do not see any process named eynio or similar.

as this is just a web application, it may be part of nodejs
Narayan
 
Posts: 11
Joined: Fri Mar 11, 2016 4:36 am

Re: HTTP ERROR 403

Postby orion » Wed Jul 18, 2018 11:10 am

mm... I just installed this server on my NAS. Everything's normal. I can launch this app within my LAN environment without problems. I can see welcome web page. Not sure why you get error 403. That should be caused by your working environment.
User avatar
orion
 
Posts: 2424
Joined: Wed May 29, 2013 11:09 am

Re: HTTP ERROR 403

Postby Narayan » Thu Jul 19, 2018 3:08 am

Hi Orion.

My NAS has only official Asustor APPS and common configuration that i set acording to asustors tutorials.

The question is: how can I debug the problem? As the 403 sounds like a permissions problem and it does not even work with my admin account, how can I check/repair permissions?

Thank you in advance
Narayan
 
Posts: 11
Joined: Fri Mar 11, 2016 4:36 am

Re: HTTP ERROR 403

Postby orion » Thu Jul 19, 2018 10:14 am

If you setup app access rights correctly under ADM -> Access Control, most-likely, you'll need to find the log of Eynio to check what's the major error. I have no ideas about this app.
Last edited by orion on Thu Jul 19, 2018 4:27 pm, edited 1 time in total.
User avatar
orion
 
Posts: 2424
Joined: Wed May 29, 2013 11:09 am

Re: HTTP ERROR 403

Postby sksbir » Thu Jul 19, 2018 4:17 pm

Narayan wrote:Hi Orion.
My NAS has only official Asustor APPS and common configuration that i set acording to asustors tutorials.
The question is: how can I debug the problem? As the 403 sounds like a permissions problem and it does not even work with my admin account, how can I check/repair permissions?
Thank you in advance

Even admin may not have all app permissions. Did you check that ? ( Access control ==> app privileges )
sksbir
 
Posts: 322
Joined: Tue Aug 25, 2015 9:23 pm

Previous

Return to Eynio Server

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest